Dome light not working - S2KI Honda S2000 Forums



Dome light not working

Reply
 
 
 
Thread Tools
Old 01-23-2007, 05:14 PM   #1
Registered User
Thread Starter
 
Enthralled's Avatar
 
Join Date: Nov 2005
Location: Los Angeles, CA
Posts: 14,373
Thanks: 0
Thanked 0 Times in 0 Posts
Default Dome light not working

well...when i open my car door the lights don't come on but when i manually press the buttons it does...any thoughts?



peace
Enthralled is offline   Reply With Quote
Old 01-23-2007, 05:15 PM   #2
Member
 
Slows2k's Avatar
 
Join Date: Sep 2002
Location: Mother F'in TN
Posts: 35,316
Thanked 2 Times in 2 Posts
Default

Put the switch to the middle position on the dome lamp.
Slows2k is offline   Reply With Quote
Old 01-23-2007, 05:15 PM   #3
Registered User
 
Join Date: Jul 2006
Location: Tuscaloosa/Mobile, AL
Posts: 2,730
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Slows2k,Jan 23 2007, 07:15 PM
Put the switch to the middle position on the dome lamp.


Jql168 is offline   Reply With Quote
Old 01-23-2007, 05:15 PM   #4
Registered User
 
Join Date: Jul 2006
Posts: 343
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I hate asking this, but are you sure the small switch that dictates whether the lights come on when the doors open or not is in the right position? The small switch in between the two lights?

Edit: beaten by seconds
brimstone is offline   Reply With Quote
Old 01-23-2007, 05:16 PM   #5
Registered User
Thread Starter
 
Enthralled's Avatar
 
Join Date: Nov 2005
Location: Los Angeles, CA
Posts: 14,373
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Slows2k,Jan 23 2007, 05:15 PM
Put the switch to the middle position on the dome lamp.
it is on the middle one.but i tried all 3 positions aswell.I also tried pushing that little thing on the door jam also.
Enthralled is offline   Reply With Quote
Old 01-23-2007, 05:19 PM   #6
Member
 
Slows2k's Avatar
 
Join Date: Sep 2002
Location: Mother F'in TN
Posts: 35,316
Thanked 2 Times in 2 Posts
Default

Do the map lights come on with the switches?
Slows2k is offline   Reply With Quote
Old 01-23-2007, 05:24 PM   #7
Registered User
Thread Starter
 
Enthralled's Avatar
 
Join Date: Nov 2005
Location: Los Angeles, CA
Posts: 14,373
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Slows2k,Jan 23 2007, 05:19 PM
Do the map lights come on with the switches?
yes, thats what i was referring to in my OP.
Enthralled is offline   Reply With Quote
Old 01-23-2007, 05:34 PM   #8
Member
 
Slows2k's Avatar
 
Join Date: Sep 2002
Location: Mother F'in TN
Posts: 35,316
Thanked 2 Times in 2 Posts
Default

Pull both of the door jamb switches out to make sure they are plugged in. Since the dome lamps work with the switches either the door jamp switches are not plugged in or the select switch in the lamp is faulty
Slows2k is offline   Reply With Quote
Old 01-23-2007, 05:36 PM   #9
Registered User
Thread Starter
 
Enthralled's Avatar
 
Join Date: Nov 2005
Location: Los Angeles, CA
Posts: 14,373
Thanks: 0
Thanked 0 Times in 0 Posts
Default

^^thanks. i'll check it out tomorrow.



peace
Enthralled is offline   Reply With Quote
Old 04-08-2007, 01:47 AM   #10
Registered User
 
Join Date: Mar 2006
Location: Gurenderu
Posts: 2,649
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i dont know if the OP solved his problem by checking the door sensors.

but i solved this same exact issue and it wasnt the door sensors.

it was the contacts behind the 3 position switch that were corroded and thus not responding to any position. after reading the helms and playing with the maplight with my multimeter, i deduced that the switch had to be the problem, so then once i unscrewed it, i saw the contacts were kinda green (oxidized). not sure why. but once i cleaned it off, and pulled the springs out a bit for good measure, and put it back together, it all worked again.

the main thing that bugged me was that the cabin would not light up as i used the keyless entry or opened the doors. so it bothered me getting into a dark and unlit cabin. i thought it was my keyless entry module, so i took mine out and replaced iwth with a friends, and that didnt solve it. so it had to be somewhere with the wiring.

i hope this helps other ppl with the same problem. this was the only thread that seemed to ask the same issue in my various searches.

btw, to take off the map light, you first pry off the diffuser lens (carefully), then you unscrew the two bolts holding the rest of the maplight plastic housing. DONT TRY to pry off the maplight plastic housing, its soft plastic and will deeply score your maplight housing. yes, i know by idiots experience. so take off the lens FIRST.
S2Koupe is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
TX: 2005 Silverstone - 89,000 - Hardtop Kuro! Cars for Sale 8 12-05-2016 02:05 PM
2000 Honda S2000 w/ AP2 Updates Scracho Southern Ontario For Sale 2 11-25-2016 08:19 AM
WTB: work xd9 or similar rear wheels & coilovers nick300zx UK & Ireland For Sale and Wanted 2 11-24-2016 02:53 PM
VSA Light, (!) Light and CEL Weasel497 S2000 Under The Hood 1 11-23-2016 01:13 AM
DIY: Intermittent or Constant Daytime Running Light on dash FIX El S2000 S2000 Under The Hood 5 11-18-2016 02:13 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 10:46 PM.