Go Back  S2KI Honda S2000 Forums > General Interest > S2000 Modifications and Parts
Reload this Page >

Defective Dual Invidia N1 Exhaust??

S2000 Modifications and Parts Discussions about aftermarket products and parts including reviews, information and opinion.
Sponsored by:
Sponsored by:

Defective Dual Invidia N1 Exhaust??

 
Old 04-10-2018, 12:33 PM
  #1  
Registered User
Thread Starter
 
Join Date: Apr 2018
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default Defective Dual Invidia N1 Exhaust??

I just installed a dual invidia n1 on my 06 s2000 and on first start up i noticed its more quite then a lot of other ones that i have seen. Its quite and deep and not raspy at all. Its no where near loud. Is this normal? Is there some kind of break in time that is needed for this exhaust? Has this happen to any one before? Maybe i got a defective one? Any input would help.

Thanks
S2K_Gabe is offline  
Old 04-11-2018, 10:10 AM
  #2  
 
dc2-2-ap1's Avatar
 
Join Date: Jul 2007
Location: Phoenix, AZ
Posts: 6,337
Likes: 0
Received 26 Likes on 23 Posts
Default

You think it is defective because it is not overly loud and raspy? So you bought it to be obnoxious.
Are you running the factory cat, hfc, or a test pipe (60mm or 70mm)? A 70mm test pipe will make it to where everyone in your general area will get a headache after a few minutes of driving next to you. The factory cat keeps the noise levels in a somewhat acceptable range.
dc2-2-ap1 is offline  
Old 04-11-2018, 10:22 AM
  #3  
Site Moderator
 
Manga_Spawn's Avatar
 
Join Date: May 2011
Location: Seattle WA
Posts: 12,438
Received 142 Likes on 128 Posts
Default

Is this just on start up idle? Most exhausts don't sound crazy till you drive the car. Ditto on the question about if you are running the oem cat or test pipe. Don't worry it'll start falling apart and sound like a clapped out civic in no time.
Manga_Spawn is online now  
Old 04-11-2018, 11:11 AM
  #4  
Registered User
Thread Starter
 
Join Date: Apr 2018
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default

I have the stock cat and invidia resonator. Iv seen others that have the same setup as mine and its much louder then mine. Mine is really really deep and sounds nothing like an s2000. And this on start up and while driving. While driving the tone doesnt change, it stays really deep and as i climb up in the rpm it gets quitier.
S2K_Gabe is offline  
Old 04-11-2018, 11:14 AM
  #5  
Registered User
Thread Starter
 
Join Date: Apr 2018
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default

I previously was straight piped so this is nooooo were near obnoxious. It is really deep and doesnt change in sound at all, it actually gets quitier as i go up in the rpms. My thing is iv seen many others with the same setup, freshly installed it theirs is way louder then mine. Mine doesnt even sound like it would be an invidia n1 its that quite.
S2K_Gabe is offline  
Old 04-11-2018, 11:35 AM
  #6  
Registered User
Thread Starter
 
Join Date: Apr 2018
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default

What if i ran the n1 mufflers, resonator delete and stock cat?
S2K_Gabe is offline  
Old 04-11-2018, 11:37 AM
  #7  
Registered User
Thread Starter
 
Join Date: Apr 2018
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by dc2-2-ap1 View Post
You think it is defective because it is not overly loud and raspy? So you bought it to be obnoxious.
Are you running the factory cat, hfc, or a test pipe (60mm or 70mm)? A 70mm test pipe will make it to where everyone in your general area will get a headache after a few minutes of driving next to you. The factory cat keeps the noise levels in a somewhat acceptable range.
I have the stock cat and invidia resonator. Iv seen others that have the same setup as mine and its much louder then mine. Mine is really really deep and sounds nothing like an s2000. And this on start up and while driving. While driving the tone doesnt change, it stays really deep and as i climb up in the rpm it gets quitier. What if i ran the n1 mufflers, resonator delete and stock cat?
S2K_Gabe is offline  
Old 04-11-2018, 11:55 AM
  #8  
Registered User
Thread Starter
 
Join Date: Apr 2018
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by Manga_Spawn View Post
Is this just on start up idle? Most exhausts don't sound crazy till you drive the car. Ditto on the question about if you are running the oem cat or test pipe. Don't worry it'll start falling apart and sound like a clapped out civic in no time.
I previously was straight piped so this is nooooo were near obnoxious. It is really deep and doesnt change in sound at all, it actually gets quitier as i go up in the rpms. My thing is iv seen many others with the same setup, freshly installed it theirs is way louder then mine. Mine doesnt even sound like it would be an invidia n1 its that quite.
S2K_Gabe is offline  
Old 04-11-2018, 02:02 PM
  #9  
Site Moderator
 
Manga_Spawn's Avatar
 
Join Date: May 2011
Location: Seattle WA
Posts: 12,438
Received 142 Likes on 128 Posts
Default

Originally Posted by S2K_Gabe View Post
What if i ran the n1 mufflers, resonator delete and stock cat?
What do you mean what if you run the N1 mufflers? What mufflers are on there now? Are the silencers in the mufflers? That could account to the difference.
Manga_Spawn is online now  
Old 04-11-2018, 02:26 PM
  #10  
Registered User
Thread Starter
 
Join Date: Apr 2018
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by Manga_Spawn View Post
What do you mean what if you run the N1 mufflers? What mufflers are on there now? Are the silencers in the mufflers? That could account to the difference.
Right now i have stock cat, with invidia n1 exhaust no silencers. What if i did a resonator deleted and ran the n1 mufflers in the back with a stock cat?
S2K_Gabe is offline  

Quick Reply: Defective Dual Invidia N1 Exhaust??


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands