HKS SC kit topic - Page 199 - S2KI Honda S2000 Forums

UK & Ireland S2000 Community Discussions related to the S2000, its ownership and enthusiasm for it in the UK and Ireland. Including FAQs, and technical questions.

HKS SC kit topic

Reply

 
 
 
Old 03-13-2018, 08:10 AM
  #1981  
 
markforrester99's Avatar
 
Join Date: Apr 2012
Location: Hertfordshire
Posts: 1,624
Thanked 18 Times in 18 Posts
Default

markforrester99 is online now  
Reply With Quote
Old 03-20-2018, 05:08 AM
  #1982  
 
Join Date: May 2014
Location: Reading
Posts: 802
Thanked 24 Times in 24 Posts
Default

Sounds like you need to re position your pipe work. Mine is clear and no marks at all, I'll try get some photos when i can.
johnckeen is offline  
Reply With Quote
Old 03-21-2018, 03:52 AM
  #1983  
 
Join Date: Sep 2011
Location: Bidford on Avon
Posts: 954
Thanked 39 Times in 35 Posts
Default

Same, Mine is clear.
har-vey is offline  
Reply With Quote
Old 03-21-2018, 08:17 AM
  #1984  
 
markforrester99's Avatar
 
Join Date: Apr 2012
Location: Hertfordshire
Posts: 1,624
Thanked 18 Times in 18 Posts
Default

Mine has all changed since then but noticed the pipework when sorting through old bits of intercooler piping. Mine didn't rub when the car is running but must rock about abit when giving it some throttle. Not a bad idea to cut abit of silicon hose in half and push it over the edge so that if it does catch it doesn't cause any damage
markforrester99 is online now  
Reply With Quote
Old 04-13-2018, 02:46 PM
  #1985  
 
markforrester99's Avatar
 
Join Date: Apr 2012
Location: Hertfordshire
Posts: 1,624
Thanked 18 Times in 18 Posts
Default

markforrester99 is online now  
Reply With Quote
Old 04-14-2018, 01:37 AM
  #1986  
 
CynicG's Avatar
 
Join Date: Mar 2012
Location: Southampton/Winchester
Posts: 3,019
Thanked 25 Times in 25 Posts
Default

Jesus... same failures again! Would be interesting to know if he was using the bov supplied with the kit or not.
CynicG is offline  
Reply With Quote
Old 04-14-2018, 11:11 AM
  #1987  
 
boys2k's Avatar
 
Join Date: Apr 2015
Location: Knaphill
Posts: 622
Thanked 6 Times in 6 Posts
Default

I'm curious what HKS would say about the root cause and what they would do to rectify the issue.
boys2k is online now  
Reply With Quote
Old 04-14-2018, 02:35 PM
  #1988  
 
markforrester99's Avatar
 
Join Date: Apr 2012
Location: Hertfordshire
Posts: 1,624
Thanked 18 Times in 18 Posts
Default

On the BRZ forum there is a whole post showing the failure and it being linked to weak threads within the unit and start to strip off. Once that starts happening it quickly leads to failure.
markforrester99 is online now  
Reply With Quote
The Following User Says Thank You to markforrester99 For This Useful Post:
boys2k (04-15-2018)
Old 04-15-2018, 06:49 AM
  #1989  
 
Join Date: Sep 2011
Location: Bidford on Avon
Posts: 954
Thanked 39 Times in 35 Posts
Default

Originally Posted by markforrester99 View Post
On the BRZ forum there is a whole post showing the failure and it being linked to weak threads within the unit and start to strip off. Once that starts happening it quickly leads to failure.
Got a link to that mark? be good to have a read
har-vey is offline  
Reply With Quote
Old 04-15-2018, 06:54 AM
  #1990  
 
Join Date: May 2014
Location: Reading
Posts: 802
Thanked 24 Times in 24 Posts
Default

Was hammering around castle Combe on Thursday, car handled like a champ, didn't miss a beat.
get belt slip at around 8200rpm but meh I rarely rev it past 8, such a hoot these chargers.
johnckeen is offline  
Reply With Quote
The Following User Says Thank You to johnckeen For This Useful Post:
har-vey (04-15-2018)

Quick Reply: HKS SC kit topic


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service