Go Back  S2KI Honda S2000 Forums > General Interest > S2000 Talk
Reload this Page >

Have you guys seen this before?

S2000 Talk Discussions related to the S2000, its ownership and enthusiasm for it.

Have you guys seen this before?

 
Old 04-19-2014, 11:47 AM
  #1  
Registered User
Thread Starter
 
El Borracho Chino's Avatar
 
Join Date: Apr 2013
Posts: 111
Likes: 0
Received 0 Likes on 0 Posts
Default Have you guys seen this before?

Day one of dewinterization(my first real winter here) and spotted this heart wrenching sight on my cluster. Wondering if you guys know what it is and if it will go away?



[img=http://s14.postimg.org/3tr2r6q8d/image.jpg]
El Borracho Chino is offline  
Old 04-19-2014, 04:55 PM
  #2  
 
Fierc3's Avatar
 
Join Date: Jul 2009
Posts: 1,149
Likes: 0
Received 1 Like on 1 Post
Default

I don't think that can be undone.

Don't sweat it tho, gives ur cluster character
Fierc3 is offline  
Old 04-19-2014, 06:19 PM
  #3  
 
Minicoop19's Avatar
 
Join Date: Jul 2012
Location: 33OH
Posts: 575
Likes: 0
Received 1 Like on 1 Post
Default

I't try switching over to KM/H just to see if it gets any better when you switch back to MPH... But like ^^^^ said, IDK if anything could be done...
Go for one of these if you're plannig on replacing it: http://qube-engineering.com/S2000-LE...luster-AP1.htm
Minicoop19 is offline  
Old 04-21-2014, 04:38 AM
  #4  
Registered User
Thread Starter
 
El Borracho Chino's Avatar
 
Join Date: Apr 2013
Posts: 111
Likes: 0
Received 0 Likes on 0 Posts
Default

Switching doesn't really do anything. The weirdest things happen to cars I own I swear.
El Borracho Chino is offline  
Old 04-21-2014, 05:25 AM
  #5  
Former Moderator
 
sam_spider's Avatar
 
Join Date: Jul 2005
Location: Michigan
Posts: 37,345
Received 290 Likes on 209 Posts
Default

That's odd. It's looks almost as if it froze and broke some of the LCD thingys in the process.

Sorry to see that, that really sucks.
sam_spider is offline  
Old 04-21-2014, 12:55 PM
  #6  
Former Moderator
 
Mocky's Avatar
 
Join Date: Sep 2002
Posts: 105,348
Received 33 Likes on 27 Posts
Default

Agree. Move this thread to s2000 talk. Someone there might be able to help you there.

That's really odd
Mocky is offline  
Old 04-21-2014, 08:32 PM
  #7  
 
Join Date: Aug 2012
Location: Foothills East of Sacramento
Posts: 2,940
Received 72 Likes on 61 Posts
Default

I wonder if temperature will affect it. I have seen both cold and heat change LCD displays. However the little dots are a new one. Normally automotive parts are designed to be subjected to pretty harsh temp extremes.
cosmomiller is online now  
Old 04-21-2014, 08:48 PM
  #8  
 
RMurphy's Avatar
 
Join Date: Aug 2009
Location: West Los Angeles, CA
Posts: 5,521
Likes: 0
Received 6 Likes on 3 Posts
Default

Originally Posted by Mocky View Post
Agree. Move this thread to s2000 talk. Someone there might be able to help you there.
Electronics or Interior? I moved it here, it was in the Ohio forum
RMurphy is offline  
Old 04-21-2014, 10:00 PM
  #9  
 
na2king's Avatar
 
Join Date: Dec 2013
Posts: 553
Received 0 Likes on 0 Posts
Default

looks like your tach has an STD...

na2king is offline  
Old 04-22-2014, 05:58 AM
  #10  
 
jimboslice's Avatar
 
Join Date: Jul 2013
Location: Ellensburg
Posts: 625
Received 7 Likes on 7 Posts
Default

I've never seen an LCD screen on a car/piece of equipment crack due to low temps. I know it may sound like a dumb question, but it must be asked.

Has anything whacked the face of the cluster? That's the only thing I can think of, because it's bleeding into your "km/h."
jimboslice is offline  

Quick Reply: Have you guys seen this before?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands