S2000 Under The Hood S2000 Technical and Mechanical discussions.

CAT CEL's Came and Went

 
Old 06-22-2018, 02:03 AM
  #1  
Thread Starter
 
Join Date: Jan 2013
Posts: 61
Received 1 Like on 1 Post
Default CAT CEL's Came and Went

Driving along the other day i got a CEL. Went straight to the garage to pull the code.

P0420 (Catalyst System Efficiency Below Threshold (Bank 1)
P0430 (Catalyst System Efficiency Below Threshold (Bank 2)

The car had a new CAT from Tegiwa imports some 6 months ago maybe, not a straight pipe or anything just a sports CAT. We didn't reset the code or clear it but when i restarted the car the CEL had gone and hasn't come back on.

I don't know whether this is in my head but i had noticed for last couple of weeks the exhausts are a lot more sutty lately. Is it worth asking for a replacement?
davers is offline  
Old 06-22-2018, 02:12 AM
  #2  
 
flanders's Avatar
 
Join Date: Aug 2013
Location: Sweden
Posts: 2,840
Received 143 Likes on 139 Posts
Default

Is this the same CAT you got? TEGIWA STAINLESS STEEL HFC HIGH FLOW CAT HONDA S2000 Tegiwa Imports
Seems it got a spacer built in for the O2 sensor so the code you got should never really come on even if there was a straight pipe inside.
If the CEL wont come back I wouldn't worry to much and just keep driving. If you got mandatory emissions test in your country that's the real test if the CAT is really bad.
flanders is online now  
Old 06-22-2018, 03:11 AM
  #3  
 
ISADE's Avatar
 
Join Date: Feb 2010
Location: Ohio
Posts: 249
Received 7 Likes on 7 Posts
Default

I recently got a Mazda 6 so I've had to do a ton of research on cat since this car has 4 of them and I got a P0421 code.
For you I would either forget about it until it comes back on or if you're worried (or it comes back on), remove the CAT and clean it by soaking it in what I've seen suggested is a mix of water and laundry detergent, overnight (I've seen videos of people running some lacquer thinner through the gas engine, I'm not a huge fan of this idea yet). There's no way after 6 months the catalyst that reacts has all been used up, perhaps it's all dirty and clogged up in there OR the honeycomb material has broken apart but i'm going to guess it might be getting clogged up.

If you think you are seeing sooty exhaust though maybe your engine is running rich? Make sure you're up to date on preventative maintenance items so that you're running in tip top shape.
ISADE is offline  
Old 06-22-2018, 03:47 AM
  #4  
 
Join Date: Aug 2012
Posts: 4,627
Likes: 0
Received 266 Likes on 236 Posts
Default

Bank 2?
Car Analogy is online now  
Old 06-23-2018, 09:13 AM
  #5  
Thread Starter
 
Join Date: Jan 2013
Posts: 61
Received 1 Like on 1 Post
Default

Originally Posted by flanders View Post
Is this the same CAT you got? TEGIWA STAINLESS STEEL HFC HIGH FLOW CAT HONDA S2000 Tegiwa Imports
Seems it got a spacer built in for the O2 sensor so the code you got should never really come on even if there was a straight pipe inside.
If the CEL wont come back I wouldn't worry to much and just keep driving. If you got mandatory emissions test in your country that's the real test if the CAT is really bad.
Yeah that's the one, and it came back on again today, 4 days later. Pretty annoyed given when i ordered it it took 2 months to actually arrive so had to drive round with a rattling cat for ages.

What now? Look for a replacement?
davers is offline  
Old 06-23-2018, 09:26 AM
  #6  
 
flanders's Avatar
 
Join Date: Aug 2013
Location: Sweden
Posts: 2,840
Received 143 Likes on 139 Posts
Default

You got the same codes again and are you really sure one of them was P0430?
I don't think that one is a valid code on our cars.
flanders is online now  
Old 06-24-2018, 02:44 AM
  #7  
Thread Starter
 
Join Date: Jan 2013
Posts: 61
Received 1 Like on 1 Post
Default

Yeah took a photo of them. CAT is around 9 months old. Threw the same codes P0420 & P0430
davers is offline  
Old 06-24-2018, 03:25 AM
  #8  
 
flanders's Avatar
 
Join Date: Aug 2013
Location: Sweden
Posts: 2,840
Received 143 Likes on 139 Posts
Default

Did you check your O2 sensor for any damage before you replaced your damaged cat?
flanders is online now  
Old 06-24-2018, 09:44 AM
  #9  
Thread Starter
 
Join Date: Jan 2013
Posts: 61
Received 1 Like on 1 Post
Default

The garage had a look over it all before replacing the CAT. All seemed fine, only reason the original cat was replaced was because it started rattling. Didn't even throw a CEL just rattling when sat stationary.
davers is offline  
Old 06-24-2018, 11:28 AM
  #10  
 
flanders's Avatar
 
Join Date: Aug 2013
Location: Sweden
Posts: 2,840
Received 143 Likes on 139 Posts
Default

Since there is no bank 2 sensor the P0430 code suggests something else is wrong besides the CAT not working correctly.
It's not uncommon for the CAT insides to come loose and mechanically damage the sensor so maybe it's worth to have a look.
While you are there you might as well ad another spacer, like this for example https://www.ebay.co.uk/itm/221932109599
flanders is online now  

Quick Reply: CAT CEL's Came and Went


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands