S2000 Racing and Competition The S2000 on the track and Solo circuit. Some of the fastest S2000 drivers in the world call this forum home.
Sponsored by:
Sponsored by:

Right turns loss of power

 
Old 04-24-2017, 08:22 AM
  #1  
Thread Starter
 
f20kills's Avatar
 
Join Date: Jun 2002
Location: Mom!!! The Meatloaf!!
Posts: 4,695
Received 12 Likes on 11 Posts
Default Right turns loss of power

Loss of power. Feels like a miss fire. Yes I know about right turns and proper valve cover venting and Ive done a lot of different configurations lol

So my car only does this on right turns, not on left. My car is 2.4 13:1 motor and I've done the valve cover mod. My catch can is connected at both factory vents and vents to the atmosphere through one catch can. Nothing recirculates to the intake mani. If I have less oil in the motor, the car does not do it a often or as pronounced. Half quart low.

Any ideas? Maybe not even oil related...fuel pressure? Too much compression? Should I have it recirculate to the mani?

Open to any ideas..thanks!
f20kills is offline  
Old 04-24-2017, 08:26 AM
  #2  
Thread Starter
 
f20kills's Avatar
 
Join Date: Jun 2002
Location: Mom!!! The Meatloaf!!
Posts: 4,695
Received 12 Likes on 11 Posts
Default

BTW...My car never did this before the 2.4 swap. 2.2 I had no issues.
its been like this day one when I put this motor in.
f20kills is offline  
Old 04-24-2017, 08:37 AM
  #3  
 
Join Date: Nov 2011
Posts: 828
Received 45 Likes on 27 Posts
Default

How significant is the power loss? Does it feel like it does when it ingests oil, or more like fuel cut?
anorexicpoodle is offline  
Old 04-24-2017, 08:53 AM
  #4  
Thread Starter
 
f20kills's Avatar
 
Join Date: Jun 2002
Location: Mom!!! The Meatloaf!!
Posts: 4,695
Received 12 Likes on 11 Posts
Default

Originally Posted by anorexicpoodle View Post
How significant is the power loss? Does it feel like it does when it ingests oil, or more like fuel cut?
More like when it ingests oil. Feels like its down on power pretty good. Definitely not fuel cut. In the cooler weather too it seems like its not so bad.
I was thinking maybe spark plug gap but it doesn't seem to do it on left turns...so Im lost lol
f20kills is offline  
Old 04-24-2017, 09:08 AM
  #5  
Community Organizer
 
s2000Junky's Avatar
 
Join Date: Jun 2007
Posts: 28,575
Received 248 Likes on 233 Posts
Default

Weird. Still seems like oil getting in the combustion chamber. I've never had this issue on any of my motors so I'm probably not the most experienced at troubleshooting this one. But if consumption is severe enough for the engine to bog, id think there would be some signs present, either a cloud of blue smoke behind you or some oil contamination signs on your plugs. Both of which can be a hard chase since you cant just pull over mid apex to pull a plug and see, and unless its a hug cloud, you are not usually going to see it, but the guy behind you might if your so lucky to talk to him.
s2000Junky is online now  
Old 04-24-2017, 09:13 AM
  #6  
Thread Starter
 
f20kills's Avatar
 
Join Date: Jun 2002
Location: Mom!!! The Meatloaf!!
Posts: 4,695
Received 12 Likes on 11 Posts
Default

Originally Posted by s2000Junky View Post
Weird. Still seems like oil getting in the combustion chamber. I've never had this issue on any of my motors so I'm probably not the most experienced at troubleshooting this one. But if consumption is severe enough for the engine to bog, id think there would be some signs present, either a cloud of blue smoke behind you or some oil contamination signs on your plugs. Both of which can be a hard chase since you cant just pull over mid apex to pull a plug and see, and unless its a hug cloud, you are not usually going to see it, but the guy behind you might if your so lucky to talk to him.
Yeah..it seems like oil is getting in there but I dont have oil consumption and no smoke which is weird. I track with my buds and they've never seem me blow smoke while behind me.
f20kills is offline  
Old 04-24-2017, 10:57 AM
  #7  
Community Organizer
 
s2000Junky's Avatar
 
Join Date: Jun 2007
Posts: 28,575
Received 248 Likes on 233 Posts
Default

Originally Posted by f20kills View Post
Yeah..it seems like oil is getting in there but I dont have oil consumption and no smoke which is weird. I track with my buds and they've never seem me blow smoke while behind me.
How do your plugs look?
s2000Junky is online now  
Old 04-24-2017, 11:08 AM
  #8  
 
Join Date: Jul 2002
Location: Orlando
Posts: 2,711
Received 31 Likes on 23 Posts
Default

Clearly your Motec is cutting power for traction control.
Mrsideways is offline  
Old 04-24-2017, 11:08 AM
  #9  
Thread Starter
 
f20kills's Avatar
 
Join Date: Jun 2002
Location: Mom!!! The Meatloaf!!
Posts: 4,695
Received 12 Likes on 11 Posts
Default

Originally Posted by s2000Junky View Post
How do your plugs look?

Last time I checked them, perfect. No oil, not too dark, not too light.
Ill pull them again to double check just to be sure. Ill measure the gap too.
f20kills is offline  
Old 04-24-2017, 11:08 AM
  #10  
 
s2000ellier's Avatar
 
Join Date: Aug 2011
Location: Florida
Posts: 4,186
Received 65 Likes on 51 Posts
Default

turn on your data logging and check if you are logging a misfire

lateral load causing a wire to ground/short leading to misfire?
s2000ellier is offline  

Quick Reply: Right turns loss of power


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands