Go Back  S2KI Honda S2000 Forums > General Interest > S2000 Talk
Reload this Page >

What did you do to your S2000 today?

S2000 Talk Discussions related to the S2000, its ownership and enthusiasm for it.

What did you do to your S2000 today?

 
Old 02-19-2016, 02:25 AM
  #11  
 
NNY S2k's Avatar
 
Join Date: Mar 2002
Location: Plattsburgh, NY
Posts: 23,403
Received 82 Likes on 75 Posts
Default

Originally Posted by gerry100 View Post
checked to see if the battery tender was still lit up
X2
Levi


NNY S2k is offline  
Old 02-19-2016, 03:24 AM
  #12  
Former Moderator
 
zdave87's Avatar
 
Join Date: Apr 2004
Posts: 77,486
Received 222 Likes on 210 Posts
Default

Looked at it.
zdave87 is offline  
Old 02-19-2016, 04:40 PM
  #13  
Thread Starter
 
Driftingcloud's Avatar
 
Join Date: Jan 2016
Posts: 35
Likes: 0
Received 2 Likes on 2 Posts
Default

Originally Posted by rrounds View Post
I drove it.

ROD
Always a great answer!
Driftingcloud is offline  
Old 02-19-2016, 07:19 PM
  #14  
 
zeroptzero's Avatar
 
Join Date: Oct 2009
Location: Out There
Posts: 14,998
Received 91 Likes on 90 Posts
Default

I replaced a couple ball joints, I had some low mileage spares sitting around and the boots on my factory ones were cracked, so it was a good time to swap them out.
zeroptzero is offline  
Old 02-19-2016, 07:50 PM
  #15  
Registered User
 
Join Date: Aug 2015
Posts: 89
Likes: 0
Received 0 Likes on 0 Posts
Default

Mounted the intercooler and ran the charge pipes. Prayed for warm weather so this snow will melt.
Highpsis2k is offline  
Old 02-19-2016, 08:46 PM
  #16  
 
Join Date: Aug 2015
Location: Chicagoland Area
Posts: 250
Received 15 Likes on 10 Posts
Default

Drove it for real for the first time! Removed plasti dip PO had put on all the exterior logos. Removed window tint and glue.
ChiHonda is offline  
Old 02-22-2016, 05:31 AM
  #17  
 
Join Date: Nov 2004
Posts: 894
Likes: 0
Received 11 Likes on 8 Posts
Default

Replaced passenger side engine mount. Turns out the mount wasn't broken, it just sagged a lot. Made an immediate difference in vibration so I might just replace the driver side too.

While I was down there, I noticed the alignment was all over the place. No wonder my front tires are wearing unevenly..
GSteg is offline  
Old 02-22-2016, 06:56 AM
  #18  
 
Join Date: Jan 2010
Posts: 1,251
Received 10 Likes on 10 Posts
Default

Originally Posted by NNY S2k View Post
Originally Posted by gerry100' timestamp='1455822691' post='23884385
checked to see if the battery tender was still lit up
X2
Levi
I think I jinxed myself. Looked again and the red light was flashing indicating a bad battery. That may be from the -15 cold snap we had.

Anybody know if I'm hurting anything by leaving it flashing. Hope to get it inspected in April without losing the codes
gerry100 is offline  
Old 02-22-2016, 08:03 AM
  #19  
 
Conedodger's Avatar
 
Join Date: Jul 2003
Location: Upstate NY
Posts: 13,458
Received 22 Likes on 21 Posts
Default

Originally Posted by gerry100 View Post
Originally Posted by NNY S2k' timestamp='1455881144' post='23884887
[quote name='gerry100' timestamp='1455822691' post='23884385']
checked to see if the battery tender was still lit up
X2
Levi
I think I jinxed myself. Looked again and the red light was flashing indicating a bad battery. That may be from the -15 cold snap we had.

Anybody know if I'm hurting anything by leaving it flashing. Hope to get it inspected in April without losing the codes
[/quote]
Unplug the Tender, check/twist the connections between the tender and the battery, and plug it back in. You may have lost a connection.
Conedodger is offline  
Old 02-22-2016, 01:42 PM
  #20  
 
Join Date: Jan 2010
Posts: 1,251
Received 10 Likes on 10 Posts
Default

Originally Posted by Conedodger View Post
Originally Posted by gerry100' timestamp='1456156614' post='23887492
[quote name='NNY S2k' timestamp='1455881144' post='23884887']
[quote name='gerry100' timestamp='1455822691' post='23884385']
checked to see if the battery tender was still lit up
X2
Levi
I think I jinxed myself. Looked again and the red light was flashing indicating a bad battery. That may be from the -15 cold snap we had.

Anybody know if I'm hurting anything by leaving it flashing. Hope to get it inspected in April without losing the codes
[/quote]
Unplug the Tender, check/twist the connections between the tender and the battery, and plug it back in. You may have lost a connection.
[/quote]

Good tip. I actually did this yesterday and it worked for a while before the bad battery light started flashing again.

Did it again on your suggestion and it seems to be working for a few hours, We'll see if we get to full charge. Battery is 6 year old
gerry100 is offline  

Quick Reply: What did you do to your S2000 today?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands