S2000 cutting out - S2KI Honda S2000 Forums

Notices
S2000 Under The Hood S2000 Technical and Mechanical discussions.

S2000 cutting out

 
Old 12-05-2018, 11:57 AM
  #1  
Registered User
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default S2000 cutting out

Hi folks new to this thot ad give it a bash my Honda went into a limp mode the other day and wen a got computer on it says fault was oil sensor or something so a checked oil and put code out stil no vtec coming in and wen a put clutch in wen driving it engine cut out any idea plz as am a plumber no to clued up on fixing
Thomas1986 is offline  
Old 12-05-2018, 02:28 PM
  #2  
 
Join Date: Aug 2012
Posts: 4,193
Thanks: 0
Thanked 209 Times in 184 Posts
Default

Apparently not a fan of punctuation either...

Its difficult to yell what you mean. I'll assume you are trying to say that the engine runs normally for general driving, but whenever you try and engage vtec, it 'cuts out', in the sense that vtec does not occur. The power is simply not there.

That combined with the oil related trouble code has me thinking its a clogged vtec screen. An easy fix for someone with decent diy skills.

You remove vtec solenoid, clean the wire mesh screen, reassemble.

I would suggest finding someone local to help you with this...

This may not be the issue, but its easy to do and seems to align with your symptoms. So try this first.
Car Analogy is offline  
Old 12-05-2018, 11:27 PM
  #3  
Registered User
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

No getting vtech at all mate and wen driving normal
and press down on clutch the car just cuts outs
and ignition lights come on
Thomas1986 is offline  
Old 12-05-2018, 11:28 PM
  #4  
Registered User
Thread Starter
 
Join Date: Dec 2018
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

And thanks folks for giving me advice
Thomas1986 is offline  
Old 01-24-2019, 09:11 AM
  #5  
Registered User
 
Join Date: Mar 2017
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by Thomas1986 View Post
And thanks folks for giving me advice
Check your MAP sensor. It might not have failed completely, but on it's way out. Also, clean the MAP tunnel, small hole it reads from. I think they cost less than $150.
minubaba is online now  
Old 01-31-2019, 10:39 PM
  #6  
 
Join Date: Apr 2003
Location: Temple City
Posts: 8,214
Thanks: 0
Thanked 31 Times in 29 Posts
Default

what was the fault code?

maybe related to your idle air control
jyeung528 is offline  
Old 01-31-2019, 11:08 PM
  #7  
Community Organizer
 
s2000Junky's Avatar
 
Join Date: Jun 2007
Posts: 27,891
Thanked 194 Times in 183 Posts
Default

Originally Posted by Thomas1986 View Post
Hi folks new to this thot ad give it a bash my Honda went into a limp mode the other day and wen a got computer on it says fault was oil sensor or something so a checked oil and put code out stil no vtec coming in and wen a put clutch in wen driving it engine cut out any idea plz as am a plumber no to clued up on fixing
Doesn't sound good. Did you run the oil real low?
s2000Junky is online now  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Thomas1986
Introductions
1
12-14-2018 09:13 AM
Thomas1986
S2000 Under The Hood
6
12-08-2018 01:36 AM
tnolo585
S2000 Under The Hood
7
07-21-2009 03:04 PM
brunodkid99
S2000 Talk
9
06-09-2007 08:03 AM
hahnn002
S2000 Under The Hood
25
06-15-2006 01:39 PM


Quick Reply: S2000 cutting out


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands