Go Back  S2KI Honda S2000 Forums > General Interest > S2000 Under The Hood > Engine Swaps
Reload this Page >

The calm before the storm (v8 swap)

Engine Swaps Discussion of alternate engine swaps into the S2000 other than F20/22. K24, 2JZ, V6, V8 etc...

The calm before the storm (v8 swap)

 
Old 07-14-2018, 01:00 PM
  #31  
Registered User
Thread Starter
 
Join Date: Jun 2016
Posts: 1,176
Received 12 Likes on 12 Posts
Default




MorngWoodStewie is offline  
Old 07-14-2018, 01:10 PM
  #32  
Registered User
Thread Starter
 
Join Date: Jun 2016
Posts: 1,176
Received 12 Likes on 12 Posts
Default












MorngWoodStewie is offline  
Old 07-14-2018, 08:21 PM
  #33  
Registered User
Thread Starter
 
Join Date: Jun 2016
Posts: 1,176
Received 12 Likes on 12 Posts
Default

Think I am done for the day.


Last edited by MorngWoodStewie; 07-14-2018 at 08:24 PM.
MorngWoodStewie is offline  
Old 07-14-2018, 08:44 PM
  #34  
Registered User
 
Join Date: Jul 2017
Posts: 500
Likes: 0
Received 20 Likes on 19 Posts
Default

Looks good man, you’re moving at a fast pace.
Nfinitecc is offline  
Old 07-15-2018, 12:03 AM
  #35  
Registered User
Thread Starter
 
Join Date: Jun 2016
Posts: 1,176
Received 12 Likes on 12 Posts
Default

My garage concurs lol. Tomorrow will be a clean up and re-check (go over whats done) and list out what needs done. At a nice spot now I think. Most of the problematic area’s are either resolved or I know what I need.


MorngWoodStewie is offline  
Old 07-17-2018, 10:02 PM
  #36  
Registered User
Thread Starter
 
Join Date: Jun 2016
Posts: 1,176
Received 12 Likes on 12 Posts
Default


My welding is not glorious by a long shot. Done with a lincoln flux core mig. She’ll hold tho.


Tack’d up.


Glorious thing about a v8 Is once you finish one you have another to do! Lol


O2 bungs installed


Downpipes ready for exhaust shop
MorngWoodStewie is offline  
Old 07-17-2018, 10:07 PM
  #37  
Registered User
Thread Starter
 
Join Date: Jun 2016
Posts: 1,176
Received 12 Likes on 12 Posts
Default


Made a heat shield for the drivers side corner, their is just so much going on right there I wanted an extra barracade.


Ballpeen hammah and some sheet metal, little shaping. I like it.

MorngWoodStewie is offline  
Old 07-17-2018, 10:16 PM
  #38  
Registered User
Thread Starter
 
Join Date: Jun 2016
Posts: 1,176
Received 12 Likes on 12 Posts
Default


Fuel system complete, just need to run the + w/fuse from cabin to battery terminal. Clutch bled, alternator charging output routed to fuse box.


MorngWoodStewie is offline  
Old 07-18-2018, 05:56 PM
  #39  
Registered User
Thread Starter
 
Join Date: Jun 2016
Posts: 1,176
Received 12 Likes on 12 Posts
Default


Little LOJ swap heater bypass bracket


Knurled riv nut fun.






Heater core hose routing :check:
MorngWoodStewie is offline  
Old 07-21-2018, 09:57 PM
  #40  
Registered User
Thread Starter
 
Join Date: Jun 2016
Posts: 1,176
Received 12 Likes on 12 Posts
Default

Im glad I started getting worried about performing checks on the harness. So I prepared for initial start-up, just clicking. I first assumed it was batterie and after getting it tested and fiddling around some more I started becoming suspicious of the draw and amps that the tweaked harness was capable of; now I could not have it “grounded” well enough (its straight to the cylinder head, another 8ga off the bottom end to subframe) but I ran an 8ga from original EPS 70amp fused terminal and it started cranking right over. Ok! Got it started... no throttle. Day later and some time on ls1tech.com I figured id try some of the information given there... swapped two pins on the pedal connector, still nothing. After probably racking my head for another couple of hours I reset the ecu and blam! Got throttle. Must have tripped a cel when it was initially pinned wrong and needed a reset. Next, the coolant gauge (only been able to get it up to one bar) no gauge, no fans (I’m assuming) so I dont want to leave it running for any period of time. Been through them both resistances go up as it gets hotter; all good at the sensor’s. Now I remember I never re flashed my ecu back to stock before starting all this big mistake on my end. So I grab my k tuner and hook it up to port... no ecu link. Well sh*t. Checking everything I notice my IG coil fuse blown. If I pull out the far left ecu connector from tweaked harness it does not blow, as soon as I plug it in, it blows. Turn key off, disconnect batterie, install fuse, install connector, connect batterie, turn key on, blow fuse.... soo no fixin that yet. Oh and I had to run my own switched 12v source for my fuel pump relay. My oem switched signal is suddenly not working anymore (maybe the harness has nothing to do with it). Hope to have a good productive conversation with someone come Mon. Thats just insane; for the amount he charges?? Wtf...
MorngWoodStewie is offline  

Quick Reply: The calm before the storm (v8 swap)


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands