RPM Stumbles after revving - S2KI Honda S2000 Forums

Notices
S2000 Engine Management Engine management topics, map and advice.

RPM Stumbles after revving

Old 08-02-2018, 10:30 PM
  #1  
Thread Starter
 
Snakecharmer's Avatar
 
Join Date: Aug 2015
Location: Land of The Prince Bishops
Posts: 90
Thanked 1 Time in 1 Post
Default RPM Stumbles after revving

I think this subject has been broached over and over again but nothing I have read so far has helped me cure my problem. So here goes......
Rev the engine and when it returns to idle the engine sometimes shudders as the revs drop to around 60r7k for a second. Same thing happens when I pull away without giving it plenty of revs.

I have set the TPS to as near to 6% as possible (5.9%) I have thoroughly stripped and cleaned the IAC valve. I have replaces the MAP sensor and thoroughly
cleaned the throttle body and adjusted the throttle cable. I have re-learned the ECU god knows how many times and my code reader shows no fault codes. Both O2 sensors read between 0-1volt. The car has 54,000 miles and otherwise runs fine, on the cam and off (VTEC). Valve clearances also double checked. It has done this since I purchased it 3 years ago and I would really love to finally sort out the problem once and for all. It seems odd that it does not do it every time the engine returns to idle. Please help!

http://www.youtube.com/watch?v=4dd_V...ature=youtu.be
Snakecharmer is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Kyle
S2000 Under The Hood
10
10-21-2018 11:28 PM
njmatt
S2000 Under The Hood
34
09-15-2018 08:39 PM
Snakecharmer
UK & Ireland S2000 Community
18
08-11-2018 05:25 AM
schwissig
S2000 Under The Hood
3
08-14-2013 10:07 PM
whasupman
Upper Mid-West S2000 Owners
10
09-15-2009 08:54 AM


Quick Reply: RPM Stumbles after revving


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands