S2000 Under The Hood S2000 Technical and Mechanical discussions.

Nice clutch

 
Old 03-05-2001, 01:53 PM
  #1  
Thread Starter
 
Join Date: Oct 2000
Location: Silver Spring
Posts: 315
Likes: 0
Received 0 Likes on 0 Posts
Default

At the autox this past saturday, I was getting ready to do my second run when my clutch wouldn't grab at the starting line. I didn't do a really agressive launch, ~5500 rpm but I was slipping it some, but I couldn't break my tires loose and it resulted in my clutch not grabbing for about 2 seconds or so. Is our clutch that bad that it won't grab when the tires are fully warmed up? Has this happened to anyone else? I have ~ 4000 miles on it.
autoxEX is offline  
Old 03-05-2001, 03:07 PM
  #2  
 
Utah S2K's Avatar
 
Join Date: Dec 2000
Location: Ogden
Posts: 4,285
Received 3 Likes on 3 Posts
Default

News flash....dumping the clutch fries clutches on any car. This is why there are aftermarket racing clutches available.
I sure a new clutch can spin warmed tires, but after a few trips you'll be ready for an aftermarket. IMHO
Utah S2K is offline  
Old 03-05-2001, 05:09 PM
  #3  
 
Join Date: Jan 2001
Location: Laurel
Posts: 2,708
Likes: 0
Received 0 Likes on 0 Posts
Default

When I drive really hard, I get a profound clutch stink (no I don't have this problem on other cars). Anyone else notice this?
jschmidt is offline  
Old 03-06-2001, 12:36 PM
  #4  
 
Pinky's Avatar
 
Join Date: Oct 2000
Location: Chapel Hill, NC
Posts: 8,293
Received 18 Likes on 16 Posts
Default

News flash.....upgrading clutch to make tires spin fries LSD!
Pinky is online now  
Old 03-06-2001, 01:07 PM
  #5  
Moderator
 
AusS2000's Avatar
 
Join Date: Oct 2000
Location: Sydney
Posts: 30,790
Likes: 0
Received 1 Like on 1 Post
Default

[QUOTE]Originally posted by fisch
[B]the stock clutch is an absolute piece of shit.
AusS2000 is offline  
Old 03-07-2001, 04:38 AM
  #6  
CG
 
Join Date: Oct 2000
Location: In the heart of the USSA!
Posts: 7,027
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally posted by jschmidt
When I drive really hard, I get a profound clutch stink (no I don't have this problem on other cars). Anyone else notice this?
If I run my car up from a low speed to 100 or 110mph without power shifting but shifting near 9K I always get the clutch stink. My clutch was replaced with the 2nd gear grind fix and both clutches have done it.
CG is offline  
Old 03-07-2001, 05:02 AM
  #7  
 
Join Date: Oct 2000
Location: Nashvegas
Posts: 17,204
Likes: 0
Received 4 Likes on 3 Posts
Default

NO CLUTCH PROBLEMS HERE! STILL ORIGINAL and going fine!

gone through some tires though.

I did have the original one time clutch slippage back at 1300 miles or so, but nothing but crisp clean shifts since.

Maybe the color---RED--- has something to do with it?

Scot
Scot is offline  
Old 03-11-2001, 12:12 AM
  #8  
 
Join Date: Nov 2000
Location: Wilmington
Posts: 378
Likes: 0
Received 0 Likes on 0 Posts
Default

Mine always had a stinky fishy smell. When my diff was acting funny and honda put it on the lift to turn the tires...the clutch was frying then..and they only had the motor turning at 4grand..and the car wasnt under any load being up on the lift.

Des,
G1S2k is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
REVZ TO9
S2000 Talk
10
09-25-2006 08:33 PM
ndcrusin17
S2000 Talk
16
02-23-2003 12:01 PM
Eze8199
S2000 Talk
20
08-07-2001 08:49 AM
mrwong
S2000 Under The Hood
2
07-05-2001 01:15 PM


Quick Reply: Nice clutch


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands