S2000 Under The Hood S2000 Technical and Mechanical discussions.

Pedal is sticky at start?

 
Old 09-14-2018, 08:45 AM
  #1  
Registered User
Thread Starter
 
Join Date: Sep 2018
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Unhappy Pedal is sticky at start?

Hi guys, I have googled my issue but I can't seem to find a clear solution. So first off I have an 08 92000 miles. So long story short my clutch pedal is perfect, given I did replace/regreased the slave cylinder which took care of some squeaking. BUT I was hoping in replacing the slave that it would take care of the friction/"sticky point I have when I press on my clutch pedal. You see its not that it stick mid-way, or at the bottom, it sticks where right at the initial point. Like it feels almost like maybe there's not enough grease or something on the pedal, not sure if I am explaining correctly. This doesn't happen much at low RPM's but it seems to happen a lot when I am at high speeds and shifting to the next gear. After I push the pedal past this friction point its perfect, bounces back fine and car shifts good. Any ideas?! Do I need to replace master cylinder? Thanks!!
vinom is offline  
Old 09-14-2018, 10:54 AM
  #2  
Registered User
Thread Starter
 
Join Date: Sep 2018
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by Deckoz View Post
Have you regrease the piston ball of the slave? Sometimes it wears a nipple and can make it feel slightly sticky? Grind off the nipple and polish the tip.
The slave was replaced brand new and regreased I don't think its that.
vinom is offline  
Old 09-16-2018, 07:01 AM
  #3  
 
Join Date: Feb 2012
Posts: 44
Likes: 0
Received 0 Likes on 0 Posts
Default

Might be this. Might need to grease your forks tips.

https://www.s2ki.com/forums/s2000-under-hood-22/clutch-realese-bearing-guide-fork-wear-1049851/
Swarley is offline  
Old 09-16-2018, 10:36 AM
  #4  
 
zeroptzero's Avatar
 
Join Date: Oct 2009
Location: Out There
Posts: 14,992
Received 91 Likes on 90 Posts
Default

Get on your knees and operate the pedal by hand with the car shut off and see if you can detect it by hand, check the clutch rod freeplay while you are under there. Might just be a dry rusty spot on the shaft if it wasn't lubed enough in the past, not much you can do about it if that is the issue.
zeroptzero is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jkelley
S2000 Under The Hood
14
07-24-2014 05:29 PM
f24_s2k
S2000 Under The Hood
2
04-14-2012 07:39 AM
s2k#47
S2000 Under The Hood
2
04-23-2010 11:02 AM
chrisjm00
S2000 Under The Hood
20
12-04-2008 05:41 PM
heffergm
S2000 Under The Hood
4
03-21-2004 04:56 PM


Quick Reply: Pedal is sticky at start?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands